CVE-2018-1116

Published: 10 July 2018

A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.

Priority

Medium

CVSS 3 base score: 4.4

Status

Package Release Status
policykit-1
Launchpad, Ubuntu, Debian
Upstream
Released (0.105-21)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.105-20ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.105-14.1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.105-4ubuntu3.14.04.2)
Patches:
Upstream: https://cgit.freedesktop.org/polkit/commit/?id=bc7ffad53643a9c80231fc41f5582d6a8931c32c