CVE-2018-1000199

Published: 01 May 2018

The Linux Kernel version 3.18 contains a dangerous feature vulnerability in modify_user_hw_breakpoint() that can result in crash and possibly memory corruption. This attack appear to be exploitable via local code execution and the ability to use ptrace. This vulnerability appears to have been fixed in git commit f67b15037a7a50c57f72e69a6d59941ad90a0f0f.

From the Ubuntu security team

Andy Lutomirski discovered that the Linux kernel did not properly perform error handling on virtualized debug registers. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(landed pre-release in 4.15.0-19.20)
Patches:
Introduced by 44234adcdce38f83c56e05f808ce656175b4beeb
Fixed by f67b15037a7a50c57f72e69a6d59941ad90a0f0f
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1005.5)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1008.8)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1005.5)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.18.0-8.9~18.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1006.6)
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1004.5)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1009.10)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.16)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable