CVE-2018-1000024

Published: 29 January 2018

The Squid Software Foundation Squid HTTP Caching Proxy version 3.0 to 3.5.27, 4.0 to 4.0.22 contains a Incorrect Pointer Handling vulnerability in ESI Response Processing that can result in Denial of Service for all clients using the proxy.. This attack appear to be exploitable via Remote server delivers an HTTP response payload containing valid but unusual ESI syntax.. This vulnerability appears to have been fixed in 4.0.23 and later.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
squid3
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.5.23-5ubuntu2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (3.5.12-1ubuntu7.5)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [3.3.8-1ubuntu6.11])
Patches:
Upstream: http://www.squid-cache.org/Versions/v3/3.5/changesets/SQUID-2018_1.patch