Your submission was sent successfully! Close

CVE-2017-3167

Published: 19 June 2017

In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may lead to authentication requirements being bypassed.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
precise
Released (2.2.22-1ubuntu1.12)
trusty
Released (2.4.7-1ubuntu4.16)
upstream Pending
(2.2.33, 2.4.26)
xenial
Released (2.4.18-2ubuntu3.3)
yakkety
Released (2.4.18-2ubuntu4.2)
zesty
Released (2.4.25-3ubuntu2.1)
Patches:
upstream: https://www.apache.org/dist/httpd/patches/apply_to_2.2.32/CVE-2017-3167.patch
upstream: https://github.com/apache/httpd/commit/78f0f0b6585f13ec1175c7020ee01cd0237fc1ba (2.4)
upstream: https://github.com/apache/httpd/commit/7103baa2e70e37eeaf7847abaa6f3567ef2cdf73 (2.2)