CVE-2017-2668

Published: 22 June 2018

389-ds-base before versions 1.3.5.17 and 1.3.6.10 is vulnerable to an invalid pointer dereference in the way LDAP bind requests are handled. A remote unauthenticated attacker could use this flaw to make ns-slapd crash via a specially crafted LDAP bind request, resulting in denial of service.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
389-ds-base
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.5.17-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.3.7.10-1ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)