Your submission was sent successfully! Close

CVE-2017-18232

Published: 15 March 2018

The Serial Attached SCSI (SAS) implementation in the Linux kernel through 4.15.9 mishandles a mutex within libsas, which allows local users to cause a denial of service (deadlock) by triggering certain error-handling code.

From the Ubuntu security team

It was discovered that a race condition existed in the Serial Attached SCSI (SAS) implementation in the Linux kernel when handling certain error conditions. A local attacker could use this to cause a denial of service (kernel deadlock).

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-12.13)
Patches:
Introduced by 87c8331fcf72e501c3a3c0cdc5c9391ec72f7cf2
Fixed by 0558f33c06bb910e2879e355192227a8e8f0219d
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1003.3)
linux-aws-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1003.3)
linux-azure-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1003.3)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1003.3)
linux-gcp-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1003.3)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1030.32)
linux-gke-5.0
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(5.0.0-1011.11~18.04.1)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.18.0-13.14~18.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(5.0.0-15.16~18.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1003.3)
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1002.3)
linux-oracle
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1007.9)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.15.0-1006.7)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.16~rc1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4.15.0-1053.57)