CVE-2017-18185

Published: 13 February 2018

An issue was discovered in QPDF before 7.0.0. There is a large heap-based out-of-bounds read in the Pl_Buffer::write function in Pl_Buffer.cc. It is caused by an integer overflow in the PNG filter.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
qpdf
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.0-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus)
Released (8.0.2-3~16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [8.0.2-3~14.04.1])
Patches:
Upstream: https://github.com/qpdf/qpdf/commit/ec7d74a386c0b2f38990079c3b0d2a2b30be0e71
Upstream: https://github.com/qpdf/qpdf/commit/6d46346eb93d5032c08cf1e39023b5d57260a766
Upstream: https://github.com/qpdf/qpdf/commit/1868a10f8b06631362618bfc85ca8646da4b4b71