CVE-2017-16653

Published: 06 August 2018

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.

Priority

Medium

CVSS 3 base score: 5.9

Status

Package Release Status
symfony
Launchpad, Ubuntu, Debian
Upstream
Released (3.4.0+dfsg-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.4.15+dfsg-2ubuntu4)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.4.15+dfsg-2ubuntu4)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.4.6+dfsg-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist