CVE-2017-15139

Published: 27 August 2018

A vulnerability was found in openstack-cinder releases up to and including Queens, allowing newly created volumes in certain storage volume configurations to contain previous data. It specifically affects ScaleIO volumes using thin volumes and zero padding. This could lead to leakage of sensitive information between tenants.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
cinder
Launchpad, Ubuntu, Debian
Upstream
Released (2:13.0.0-2)
Ubuntu 21.04 (Hirsute Hippo)
Released (2:13.0.0~rc1-0ubuntu2)
Ubuntu 20.10 (Groovy Gorilla)
Released (2:13.0.0~rc1-0ubuntu2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2:13.0.0~rc1-0ubuntu2)
Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [code not present])
Patches:
Upstream: https://git.openstack.org/cgit/openstack/cinder/commit/?id=7feb62197d371ab7253dc86a34af6ff8b484b4df