CVE-2017-12379

Published: 29 January 2018

ClamAV AntiVirus software versions 0.99.2 and prior contain a vulnerability that could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition or potentially execute arbitrary code on an affected device. The vulnerability is due to improper input validation checking mechanisms in the message parsing function on an affected system. An unauthenticated, remote attacker could exploit this vulnerability by sending a crafted email to the affected device. This action could cause a messageAddArgument (in message.c) buffer overflow condition when ClamAV scans the malicious email, allowing the attacker to potentially cause a DoS condition or execute arbitrary code on an affected device.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
clamav
Launchpad, Ubuntu, Debian
Upstream
Released (0.99.3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.99.3+addedllvm-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.99.3+addedllvm-0ubuntu0.14.04.1)