Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2017-12194

Published: 14 March 2018

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

Notes

AuthorNote
leosilva
xenial uses spice-protocol to generate
the codes that are affected.
not all releases has the test section to add the third patch.

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
spice
Launchpad, Ubuntu, Debian
artful
Released (0.12.8-2.2ubuntu0.1)
bionic
Released (0.14.0-1ubuntu2.1)
cosmic
Released (0.14.0-1ubuntu3)
disco
Released (0.14.0-1ubuntu3)
eoan
Released (0.14.0-1ubuntu3)
focal
Released (0.14.0-1ubuntu3)
groovy
Released (0.14.0-1ubuntu3)
hirsute
Released (0.14.0-1ubuntu3)
impish
Released (0.14.0-1ubuntu3)
jammy
Released (0.14.0-1ubuntu3)
kinetic
Released (0.14.0-1ubuntu3)
precise Does not exist

trusty
Released (0.12.4-0nocelt2ubuntu1.6)
upstream Needs triage

xenial Not vulnerable

Patches:
other: https://gitlab.com/spice/spice-common/commit/617be0f74b88ce53d84d417c00696b8c1630b6ec
other: https://gitlab.com/spice/spice-common/commit/a69fb1ec3425baf0a6dadced29669f4b708da923
other: https://gitlab.com/spice/spice-common/commit/420a15b776d3334b665d4015791647e2d24583d9






spice-gtk
Launchpad, Ubuntu, Debian
artful Ignored
(reached end-of-life)
bionic Needed

cosmic Not vulnerable
(0.35-2)
disco Not vulnerable
(0.35-2)
eoan Not vulnerable
(0.35-2)
focal Not vulnerable
(0.35-2)
groovy Not vulnerable
(0.35-2)
hirsute Not vulnerable
(0.35-2)
impish Not vulnerable
(0.35-2)
jammy Not vulnerable
(0.35-2)
kinetic Not vulnerable
(0.35-2)
precise Does not exist

trusty Does not exist
(trusty was needed)
upstream
Released (0.35-1)
xenial Not vulnerable

Patches:



other: https://gitlab.com/spice/spice-common/commit/617be0f74b88ce53d84d417c00696b8c1630b6ec
other: https://gitlab.com/spice/spice-common/commit/a69fb1ec3425baf0a6dadced29669f4b708da923
other: https://gitlab.com/spice/spice-common/commit/420a15b776d3334b665d4015791647e2d24583d9



spice-protocol
Launchpad, Ubuntu, Debian
artful Not vulnerable

bionic Not vulnerable

cosmic Not vulnerable

disco Not vulnerable

eoan Not vulnerable

focal Not vulnerable

groovy Not vulnerable

hirsute Not vulnerable

impish Not vulnerable

jammy Not vulnerable

kinetic Not vulnerable

precise Does not exist

trusty Does not exist
(trusty was not-affected)
upstream Needs triage

xenial
Released (0.12.10-1ubuntu0.1)
Patches:






other: https://gitlab.com/spice/spice-common/commit/617be0f74b88ce53d84d417c00696b8c1630b6ec
other: https://gitlab.com/spice/spice-common/commit/a69fb1ec3425baf0a6dadced29669f4b708da923
other: https://gitlab.com/spice/spice-common/commit/420a15b776d3334b665d4015791647e2d24583d9

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H