CVE-2017-11147

Published: 10 July 2017

In PHP before 5.6.30 and 7.x before 7.0.15, the PHAR archive handler could be used by attackers supplying malicious archive files to crash the PHP interpreter or potentially disclose information due to a buffer over-read in the phar_parse_pharfile function in ext/phar/phar.c.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.6.30)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.5.9+dfsg-1ubuntu4.22)
Patches:
Upstream: https://github.com/php/php-src/commit/e5246580a85f031e1a3b8064edbaa55c1643a451
php7.0
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.15)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(7.0.18-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/php/php-src/commit/e5246580a85f031e1a3b8064edbaa55c1643a451
Upstream: https://github.com/php/php-src/commit/7f0de1a138a69beb7c537fd1ec84afbc91a45b19 (7.0 merge)
php7.1
Launchpad, Ubuntu, Debian
Upstream
Released (7.1.1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/php/php-src/commit/e5246580a85f031e1a3b8064edbaa55c1643a451
Upstream: https://github.com/php/php-src/commit/7f0de1a138a69beb7c537fd1ec84afbc91a45b19 (7.0 merge)
Upstream: https://github.com/php/php-src/commit/2075fb2b73c2d56c7acfb29773a2dc68b8d2f29d (7.1 merge)