CVE-2016-7951

Published: 13 December 2016

Multiple integer overflows in X.org libXtst before 1.2.3 allow remote X servers to trigger out-of-bounds memory access operations by leveraging the lack of range checks.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
libxtst
Launchpad, Ubuntu, Debian
Upstream
Released (2:1.2.2-1+deb8u1, 1.2.3-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.2.3-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.2.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.2.3-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://cgit.freedesktop.org/xorg/lib/libXtst/commit/?id=9556ad67af3129ec4a7a4f4b54a0d59701beeae3