Your submission was sent successfully! Close

CVE-2016-7949

Published: 13 December 2016

Multiple buffer overflows in the (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXrender before 0.9.10 allow remote X servers to trigger out-of-bounds write operations via vectors involving length fields.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
libxrender
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.10)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(1:0.9.10-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1:0.9.10-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1:0.9.10-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:0.9.10-1)
Ubuntu 16.04 ESM (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://cgit.freedesktop.org/xorg/lib/libXrender/commit/?id=9362c7ddd1af3b168953d0737877bc52d79c94f4