CVE-2016-6263

Published: 21 July 2016

The stringprep_utf8_nfkc_normalize function in lib/nfkc.c in libidn before 1.33 allows context-dependent attackers to cause a denial of service (out-of-bounds read and crash) via crafted UTF-8 data.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
libidn
Launchpad, Ubuntu, Debian
Upstream
Released (1.33-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.32-3ubuntu1.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.28-1ubuntu2.1)
Patches:
Upstream: http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=1fbee57ef3c72db2206dd87e4162108b2f425555