CVE-2016-5766

Published: 24 June 2016

Integer overflow in the _gd2GetHeader function in gd_gd2.c in the GD Graphics Library (aka libgd) before 2.2.3, as used in PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8, allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via crafted chunk dimensions in an image.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.1.1-4ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.1.0-3ubuntu0.2)
Patches:
Upstream: https://github.com/libgd/libgd/commit/aba3db8ba159465ecec1089027a24835a6da9cc0
Upstream: https://github.com/libgd/libgd/commit/a6a0e7feabb2a9738086a5dc96348f233c87fa79
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.5.37, 5.6.23)
Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses system gd)
php7.0
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.8)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(uses system gd)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: http://git.php.net/?p=php-src.git;a=commit;h=7722455726bec8c53458a32851d2a87982cf0eac

Notes

AuthorNote
mdeslaur
php uses the system libgd2
sbeattie
PEAR issues should go against php-pear as of xenial

References

Bugs