Your submission was sent successfully! Close

CVE-2016-3689

Published: 2 May 2016

The ims_pcu_parse_cdc_data function in drivers/input/misc/ims-pcu.c in the Linux kernel before 4.5.1 allows physically proximate attackers to cause a denial of service (system crash) via a USB device without both a master and a slave interface.

From the Ubuntu security team

It was discovered that the Linux kernel's USB driver for IMS Passenger Control Unit devices did not properly validate the device's interfaces. An attacker with physical access could use this to cause a denial of service (system crash).

Priority

Low

CVSS 3 base score: 4.6

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
precise Not vulnerable

trusty
Released (3.13.0-86.130)
upstream
Released (4.6~rc1)
wily
Released (4.2.0-36.41)
xenial
Released (4.4.0-22.39)
yakkety Not vulnerable
(4.4.0-22.39)
linux-armadaxp
Launchpad, Ubuntu, Debian
precise Not vulnerable

trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-aws
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Not vulnerable
(4.4.0-1002.2)
upstream
Released (4.6~rc1)
xenial Not vulnerable
(4.4.0-1001.10)
yakkety Does not exist

linux-flo
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.6~rc1)
wily Not vulnerable

xenial Not vulnerable

yakkety Not vulnerable

linux-gke
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.6~rc1)
xenial Not vulnerable
(4.4.0-1003.3)
yakkety Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.6~rc1)
wily Not vulnerable

xenial Not vulnerable

yakkety Not vulnerable

linux-grouper
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.6~rc1)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
yakkety Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.6~rc1)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
yakkety Does not exist

linux-linaro-omap
Launchpad, Ubuntu, Debian
precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-linaro-shared
Launchpad, Ubuntu, Debian
precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-quantal
Launchpad, Ubuntu, Debian
precise Ignored
(end-of-life)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-raring
Launchpad, Ubuntu, Debian
precise Ignored
(end-of-life)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-saucy
Launchpad, Ubuntu, Debian
precise Ignored
(end-of-life)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
precise
Released (3.13.0-86.130~precise1)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was released [3.16.0-73.95~14.04.1])
upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was released [3.19.0-59.65~14.04.1])
upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was released [4.2.0-36.41~14.04.1])
upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
precise Does not exist

trusty
Released (4.4.0-22.39~14.04.1)
upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-mako
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.6~rc1)
wily Not vulnerable

xenial Not vulnerable

yakkety Not vulnerable

linux-manta
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.6~rc1)
wily Not vulnerable

xenial Does not exist

yakkety Does not exist

linux-qcm-msm
Launchpad, Ubuntu, Debian
precise Ignored
(abandoned)
trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.6~rc1)
wily
Released (4.2.0-1029.37)
xenial
Released (4.4.0-1010.12)
yakkety Not vulnerable
(4.4.0-1010.12)
linux-snapdragon
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial
Released (4.4.0-1013.14)
yakkety Not vulnerable
(4.4.0-1013.14)
linux-ti-omap4
Launchpad, Ubuntu, Debian
precise Not vulnerable

trusty Does not exist

upstream
Released (4.6~rc1)
wily Does not exist

xenial Does not exist

yakkety Does not exist