Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2016-3065

Published: 11 April 2016

The (1) brin_page_type and (2) brin_metapage_info functions in the pageinspect extension in PostgreSQL before 9.5.x before 9.5.2 allows attackers to bypass intended access restrictions and consequently obtain sensitive server memory information or cause a denial of service (server crash) via a crafted bytea value in a BRIN index page.

Notes

AuthorNote
sbeattie
affects 9.5 only

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
postgresql-9.5
Launchpad, Ubuntu, Debian
upstream
Released (9.5.2)
precise Does not exist

trusty Does not exist

wily Does not exist

postgresql-9.4
Launchpad, Ubuntu, Debian
upstream Not vulnerable
(9.5 only)
precise Does not exist

trusty Does not exist

wily Not vulnerable
(9.5 only)
postgresql-9.3
Launchpad, Ubuntu, Debian
upstream Not vulnerable
(9.5 only)
precise Does not exist

trusty Not vulnerable
(9.5 only)
wily Does not exist

postgresql-9.1
Launchpad, Ubuntu, Debian
upstream Not vulnerable
(9.5 only)
precise Not vulnerable
(9.5 only)
trusty Does not exist
(trusty was not-affected [9.5 only])
wily Does not exist

postgresql-8.4
Launchpad, Ubuntu, Debian
upstream Not vulnerable
(9.5 only)
precise Not vulnerable
(9.5 only)
trusty Does not exist

wily Does not exist