Your submission was sent successfully! Close

CVE-2016-2126

Published: 19 December 2016

Samba version 4.0.0 up to 4.5.2 is vulnerable to privilege elevation due to incorrect handling of the PAC (Privilege Attribute Certificate) checksum. A remote, authenticated, attacker can cause the winbindd process to crash using a legitimate Kerberos ticket. A local service with access to the winbindd privileged pipe can cause winbindd to cache elevated access permissions.

From the Ubuntu security team

Volker Lendecke discovered that Kerberos PAC validation implementation in Samba contained multiple vulnerabilities. An authenticated attacker could use this to cause a denial of service or gain administrative privileges.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
samba
Launchpad, Ubuntu, Debian
precise Not vulnerable

trusty
Released (2:4.3.11+dfsg-0ubuntu0.14.04.4)
upstream Needs triage

xenial
Released (2:4.3.11+dfsg-0ubuntu0.16.04.3)
yakkety
Released (2:4.4.5+dfsg-2ubuntu5.2)
zesty
Released (2:4.4.5+dfsg-2ubuntu7)
samba4
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was needed)
trusty Does not exist

upstream Needs triage

xenial Does not exist

yakkety Does not exist

zesty Does not exist