CVE-2016-2090

Published: 13 January 2017

Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2 allows attackers to have unspecified impact via unknown vectors, which trigger a heap-based buffer overflow.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
libbsd
Launchpad, Ubuntu, Debian
Upstream
Released (0.8.2-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.8.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.8.2-1)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(0.8.2-1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.6.0-2ubuntu1+esm1)
Patches:
Upstream: http://cgit.freedesktop.org/libbsd/commit/?id=c8f0723d2b4520bdd6b9eb7c3e7976de726d7ff7