CVE-2016-2039

Published: 20 February 2016

libraries/session.inc.php in phpMyAdmin 4.0.x before 4.0.10.13, 4.4.x before 4.4.15.3, and 4.5.x before 4.5.4 does not properly generate CSRF token values, which allows remote attackers to bypass intended access restrictions by predicting a value.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
phpmyadmin
Launchpad, Ubuntu, Debian
Upstream
Released (4:4.5.4-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4:4.5.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4:4.5.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4:4.5.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4:4.5.4-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(4:4.5.4-1)
Ubuntu 14.04 ESM (Trusty Tahr) Needed

Patches:
Upstream: https://github.com/phpmyadmin/phpmyadmin/commit/6fe54dfa000dd6f43f237e859781fad7111ac1bd (4.0)
Upstream: https://github.com/phpmyadmin/phpmyadmin/commit/91638c04d1f2c3977560a5b9db3ac3879a38691b (4.4)
Upstream: https://github.com/phpmyadmin/phpmyadmin/commit/13384f7f47dadb02cfe950af0413c7d3e136df8e (4.4)
Upstream: https://github.com/phpmyadmin/phpmyadmin/commit/f20970d32c3dfdf82aef7b6c244da1f769043813 (4.5)
Upstream: https://github.com/phpmyadmin/phpmyadmin/commit/cb7748ac9cffcd1cd0f3081499cd4aafa9d1065e (4.5)