Your submission was sent successfully! Close

CVE-2015-8935

Published: 21 June 2016

The sapi_header_op function in main/SAPI.c in PHP before 5.4.38, 5.5.x before 5.5.22, and 5.6.x before 5.6.6 supports deprecated line folding without considering browser compatibility, which allows remote attackers to conduct cross-site scripting (XSS) attacks against Internet Explorer by leveraging (1) %0A%20 or (2) %0D%0A%20 mishandling in the header function.

Priority

Medium

CVSS 3 base score: 6.1

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.5.22)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.5.9+dfsg-1ubuntu4.19)
Patches:
Upstream: http://git.php.net/?p=php-src.git;a=commit;h=996faf964bba1aec06b153b370a7f20d3dd2bb8b
Upstream: http://git.php.net/?p=php-src.git;a=commit;h=9ba4db5e5d6aae8b1df934fbe26ea976b026576d
php7.0
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(7.0.4-7ubuntu2.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist