CVE-2015-8875

Published: 01 June 2016

Multiple integer overflows in the (1) pixops_composite_nearest, (2) pixops_composite_color_nearest, and (3) pixops_process functions in pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted image, which triggers a heap-based buffer overflow.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
gdk-pixbuf
Launchpad, Ubuntu, Debian
Upstream
Released (2.32.2, 2.34.0)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(2.32.2-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [2.30.7-0ubuntu1.6])
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist
(precise was released [2.26.1-1ubuntu1.5])
Patches:
Upstream: https://git.gnome.org/browse/gdk-pixbuf/commit/?id=dbfe8f70471864818bf458a39c8a99640895bd22

Notes

AuthorNote
sbeattie in their wheezy update, debian identified this fix as CVE-2015-7674-part2.patch (in 2.26.1-1+deb7u4).

References