Your submission was sent successfully! Close

CVE-2015-8869

Published: 13 June 2016

OCaml before 4.03.0 does not properly handle sign extensions, which allows remote attackers to conduct buffer overflow attacks or obtain sensitive information as demonstrated by a long string to the String.copy function.

From the Ubuntu security team

It was discovered that OCaml mishandled sign extensions. A remote attacker could use this vulnerability to steal sensitive information, cause a denial of service (crash), or possibly execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
ocaml
Launchpad, Ubuntu, Debian
Upstream
Released (4.02.3-9, 4.03.0)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.02.3-9)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.02.3-9)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.02.3-9)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.02.3-9)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (4.01.0-3ubuntu3.1)
Patches:
Upstream: https://github.com/ocaml/ocaml/commit/659615c7b100a89eafe6253e7a5b9d84d0e8df74