CVE-2015-8011

Published: 28 January 2020

Buffer overflow in the lldp_decode function in daemon/protocols/lldp.c in lldpd before 0.8.0 allows remote attackers to cause a denial of service (daemon crash) and possibly execute arbitrary code via vectors involving large management addresses and TLV boundaries.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
lldpd
Launchpad, Ubuntu, Debian
Upstream
Released (0.7.19-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.7.19-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.7.19-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.7.19-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.7.19-1)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(0.7.19-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/vincentbernat/lldpd/commit/dd4f16e7e816f2165fba76e3d162cd8d2978dcb2
openvswitch
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needed

Ubuntu 20.10 (Groovy Gorilla)
Released (2.13.1-0ubuntu1.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.13.1-0ubuntu0.20.04.3)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.9.7-0ubuntu0.18.04.2)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.5.9-0ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist