CVE-2015-7546

Published: 03 February 2016

The identity service in OpenStack Identity (Keystone) before 2015.1.3 (Kilo) and 8.0.x before 8.0.2 (Liberty) and keystonemiddleware (formerly python-keystoneclient) before 1.5.4 (Kilo) and Liberty before 2.3.3 does not properly invalidate authorization tokens when using the PKI or PKIZ token providers, which allows remote authenticated users to bypass intended access restrictions and gain access to cloud resources by manipulating byte fields within a revoked token.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
keystone
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:9.0.0-0ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was ignored)
Patches:
Upstream: https://review.openstack.org/#/c/258141/
python-keystonemiddleware
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(4.4.0-3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://review.openstack.org/#/c/258143/

Notes

AuthorNote
mdeslaur
we will not be fixing this in Ubuntu 14.04 LTS. Users are
encouraged to migrate to a different token provider as described
in the upstream advisory.

References

Bugs