Your submission was sent successfully! Close

CVE-2015-5312

Published: 26 November 2015

The xmlStringLenDecodeEntities function in parser.c in libxml2 before 2.9.3 does not properly prevent entity expansion, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted XML data, a different vulnerability than CVE-2014-3660.

Priority

Low

Status

Package Release Status
libxml2
Launchpad, Ubuntu, Debian
Upstream
Released (2.9.3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.9.1+dfsg1-3ubuntu4.6)
Patches:
Upstream: https://git.gnome.org/browse/libxml2/commit/?id=69030714cde66d525a8884bda01b9e8f0abf8e1e