Your submission was sent successfully! Close

CVE-2015-4141

Published: 1 June 2015

The WPS UPnP function in hostapd, when using WPS AP, and wpa_supplicant, when using WPS external registrar (ER), 0.7.0 through 2.4 allows remote attackers to cause a denial of service (crash) via a negative chunk length, which triggers an out-of-bounds read or heap-based buffer overflow.

Priority

Medium

Status

Package Release Status
hostapd
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was needed)
trusty Does not exist

upstream Pending
(2.5)
utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

Patches:
other: http://w1.fi/security/2015-2/0001-WPS-Fix-HTTP-chunked-transfer-encoding-parser.patch


wpa
Launchpad, Ubuntu, Debian
precise Does not exist

trusty
Released (2.1-0ubuntu1.3)
upstream Pending
(2.5)
utopic
Released (2.1-0ubuntu4.2)
vivid
Released (2.1-0ubuntu7.2)
wily
Released (2.1-0ubuntu8)
xenial
Released (2.1-0ubuntu8)
yakkety
Released (2.1-0ubuntu8)
zesty
Released (2.1-0ubuntu8)
Patches:

other: http://w1.fi/security/2015-2/0001-WPS-Fix-HTTP-chunked-transfer-encoding-parser.patch

wpasupplicant
Launchpad, Ubuntu, Debian
precise Not vulnerable
(code not built)
trusty Does not exist

upstream Pending
(2.5)
utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

Patches:


other: http://w1.fi/security/2015-2/0001-WPS-Fix-HTTP-chunked-transfer-encoding-parser.patch