CVE-2015-3210

Published: 01 June 2015

Heap-based buffer overflow in PCRE 8.34 through 8.37 and PCRE2 10.10 allows remote attackers to execute arbitrary code via a crafted regular expression, as demonstrated by /^(?P=B)((?P=B)(?J:(?P<B>c)(?P<B>a(?P=B)))>WGXCREDITS)/, a different vulnerability than CVE-2015-8384.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
pcre3
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1:8.31-2ubuntu2)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1558

Notes

AuthorNote
seth-arnold
"A number of such bugs have recently been discovered by fuzzers",
it might be a good idea to trawl the source repo for more such fixes.
mdeslaur
Debian claims introduced in
http://vcs.pcre.org/pcre?view=revision&revision=1361

was supposed to be fixed in wily (2:8.35-7ubuntu2) but got
reverted in (2:8.35-7ubuntu5) by mistake

CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
in jessie

References

Bugs