CVE-2015-2327

Published: 01 December 2015

PCRE before 8.36 mishandles the /(((a\2)|(a*)\g<-1>))*/ pattern and related patterns with certain internal recursive back references, which allows remote attackers to cause a denial of service (segmentation fault) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

Priority

Low

Status

Package Release Status
mongodb
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(uses system pcre)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses system pcre)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses system pcre)
pcre2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (2:8.35-8)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:8.38-3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:8.31-2ubuntu2.1)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1495

Notes

AuthorNote
sbeattie
mongodb package uses system pcre since 2.0.0
tyhicks
Issue affects PCRE3 only
Marking 'low' since it requires PCRE to operate on untrusted regular
expressions which is not very likely
mdeslaur
CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
in jessie

References

Bugs