CVE-2015-1258

Published: 20 May 2015

Google Chrome before 43.0.2357.65 relies on libvpx code that was not built with an appropriate --size-limit value, which allows remote attackers to trigger a negative value for a size field, and consequently cause a denial of service or possibly have unspecified other impact, via a crafted frame size in VP9 video data.

Priority

Low

Status

Package Release Status
chromium-browser
Launchpad, Ubuntu, Debian
Upstream
Released (43.0.2357.65)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (43.0.2357.81-0ubuntu1.1179)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [43.0.2357.81-0ubuntu0.14.04.1.1089])
libvpx
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

Patches:
Upstream: https://github.com/webmproject/libvpx/commit/943e43273b0a7369d07714e7fd2e19fecfb11c7c
oxide-qt
Launchpad, Ubuntu, Debian
Upstream
Released (1.7.8)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.7.8-0ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.7.8-0ubuntu0.14.04.1])