Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2014-8350

Published: 3 November 2014

Smarty before 3.1.21 allows remote attackers to bypass the secure mode restrictions and execute arbitrary PHP code as demonstrated by "{literal}<{/literal}script language=php>" in a template.

Priority

Medium

Status

Package Release Status
gallery2
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

lucid Not vulnerable
(uses system smarty)
precise Not vulnerable
(uses system smarty)
trusty Does not exist

upstream Needs triage

utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

moodle
Launchpad, Ubuntu, Debian
artful Not vulnerable
(uses system smarty)
bionic Not vulnerable
(uses system smarty)
cosmic Not vulnerable
(uses system smarty)
disco Not vulnerable
(uses system smarty)
lucid Not vulnerable
(uses system smarty)
precise Not vulnerable
(uses system smarty)
trusty Does not exist
(trusty was not-affected [uses system smarty])
upstream Needs triage

utopic Not vulnerable
(uses system smarty)
vivid Not vulnerable
(uses system smarty)
wily Not vulnerable
(uses system smarty)
xenial Not vulnerable
(uses system smarty)
yakkety Not vulnerable
(uses system smarty)
zesty Not vulnerable
(uses system smarty)
smarty
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

lucid Ignored
(end of life)
precise Ignored
(end of life)
trusty Does not exist

upstream Needs triage

utopic Does not exist

vivid Does not exist

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

smarty3
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(3.1.21-1)
cosmic Not vulnerable
(3.1.21-1)
lucid Does not exist

precise Ignored
(end of life)
trusty Does not exist
(trusty was needed)
upstream
Released (3.1.21-1)
utopic Ignored
(end of life)
vivid Ignored
(end of life)
wily Ignored
(end of life)
xenial Not vulnerable
(3.1.21-1)
yakkety Ignored
(end of life)
zesty Ignored
(end of life)
disco Not vulnerable
(3.1.21-1)