Your submission was sent successfully! Close

CVE-2014-6395

Published: 19 December 2014

Heap-based buffer overflow in the dissector_postgresql function in dissectors/ec_postgresql.c in Ettercap before 0.8.1 allows remote attackers to cause a denial of service or possibly execute arbitrary code via a crafted password length value that is inconsistent with the actual length of the password.

Priority

Medium

Status

Package Release Status
ettercap
Launchpad, Ubuntu, Debian
Upstream
Released (1:0.8.1-3)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:0.8.1-3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1:0.8.1-3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)