CVE-2012-6707

Published: 19 October 2017

WordPress through 4.8.2 uses a weak MD5-based password hashing algorithm, which makes it easier for attackers to determine cleartext values by leveraging access to the hash values. NOTE: the approach to changing this may not be fully compatible with certain use cases, such as migration of a WordPress site from a web host that uses a recent PHP version to a different web host that uses PHP 5.2. These use cases are plausible (but very unlikely) based on statistics showing widespread deployment of WordPress with obsolete PHP versions.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
wordpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.8.3)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.9.7+dfsg1-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.9.7+dfsg1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.9.5+dfsg1-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)