CVE-2011-1072

Published: 02 March 2011

The installer in PEAR before 1.9.2 allows local users to overwrite arbitrary files via a symlink attack on the package.xml file, related to the (1) download_dir, (2) cache_dir, (3) tmp_dir, and (4) pear-build-download directories, a different vulnerability than CVE-2007-2519.

Priority

Low

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.2.11.dsfg.1-1)
Patches:
Upstream: http://svn.php.net/viewvc?view=revision&revision=308687

Notes

AuthorNote
mdeslaur
pear 1.9.2 contains an incomplete fix. CVE-2011-1144 was
assigned to incomplete fix.
sbeattie
maverick and lucid at least are affected, as they contain
PEAR 1.9.1 and 1.9.0 respectively.

References

Bugs