CVE-2010-4410

Published: 06 December 2010

CRLF injection vulnerability in the header function in (1) CGI.pm before 3.50 and (2) Simple.pm in CGI::Simple 1.112 and earlier allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via vectors related to non-whitespace characters preceded by newline characters, a different vulnerability than CVE-2010-2761 and CVE-2010-3172.

Priority

Medium

Status

Package Release Status
libcgi-pm-perl
Launchpad, Ubuntu, Debian
Upstream
Released (3.50-1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(3.50-1)
Patches:
Upstream: http://perl5.git.perl.org/perl.git/commit/84601d63a7e34958da47dad1e61e27cb3bd467d1
libcgi-simple-perl
Launchpad, Ubuntu, Debian
Upstream
Released (1.111-2)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.111-2)
perl
Launchpad, Ubuntu, Debian
Upstream
Released (5.10.1-17)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(5.10.1-17ubuntu1)
Patches:
Upstream: http://perl5.git.perl.org/perl.git/commit/84601d63a7e34958da47dad1e61e27cb3bd467d1