CVE-2010-1169

Published: 18 May 2010

PostgreSQL 7.4 before 7.4.29, 8.0 before 8.0.25, 8.1 before 8.1.21, 8.2 before 8.2.17, 8.3 before 8.3.11, 8.4 before 8.4.4, and 9.0 Beta before 9.0 Beta 2 does not properly restrict PL/perl procedures, which allows remote authenticated users, with database-creation privileges, to execute arbitrary Perl code via a crafted script, related to the Safe module (aka Safe.pm) for Perl. NOTE: some sources report that this issue is the same as CVE-2010-1447.

Priority

Medium

Status

Package Release Status
postgresql-7.4
Launchpad, Ubuntu, Debian
Upstream Needs triage

postgresql-8.0
Launchpad, Ubuntu, Debian
Upstream Needs triage

postgresql-8.1
Launchpad, Ubuntu, Debian
Upstream
Released (8.1.21)
postgresql-8.2
Launchpad, Ubuntu, Debian
Upstream Needs triage

postgresql-8.3
Launchpad, Ubuntu, Debian
Upstream
Released (8.3.11)
postgresql-8.4
Launchpad, Ubuntu, Debian
Upstream
Released (8.4.4-1)