Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2009-5064

Published: 30 March 2011

** DISPUTED ** ldd in the GNU C Library (aka glibc or libc6) 2.13 and earlier allows local users to gain privileges via a Trojan horse executable file linked with a modified loader that omits certain LD_TRACE_LOADED_OBJECTS checks. NOTE: the GNU C Library vendor states "This is just nonsense. There are a gazillion other ways to introduce code if people are downloading arbitrary binaries and install them in appropriate directories or set LD_LIBRARY_PATH etc."

Notes

AuthorNote
mdeslaur
lucid+ debian packages have a fix in
debian/patches/all/local-ldd.diff
this is disputed, and is low...let's ignore.

Priority

Low

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Does not exist

karmic Ignored
(end of life)
lucid Not vulnerable
(2.11.1-0ubuntu7.8)
maverick Not vulnerable
(2.12.1-0ubuntu10.2)
upstream Needs triage

glibc
Launchpad, Ubuntu, Debian
dapper Ignored
(end of life)
hardy Ignored
(end of life)
karmic Does not exist

lucid Does not exist

maverick Does not exist

upstream Needs triage