CVE-2007-4743

Published: 06 September 2007

The original patch for CVE-2007-3999 in svc_auth_gss.c in the RPCSEC_GSS RPC library in MIT Kerberos 5 (krb5) 1.4 through 1.6.2, as used by the Kerberos administration daemon (kadmind) and other applications that use krb5, does not correctly check the buffer length in some environments and architectures, which might allow remote attackers to conduct a buffer overflow attack.

Priority

Unknown

Status

Package Release Status
krb5
Launchpad, Ubuntu, Debian
Upstream
Released (1.5.5, 1.6.3)
librpcsecgss
Launchpad, Ubuntu, Debian
Upstream
Released (0.16)

Notes

AuthorNote
kees
Debian package is missing mention of CVE-2007-4743 (and CVE-2007-4000)

References