Your submission was sent successfully! Close

USN-5543-1: Net-SNMP vulnerabilities

1 August 2022

Several security issues were fixed in Net-SNMP.

Releases

Packages

  • net-snmp - SNMP (Simple Network Management Protocol) server and applications

Details

Yu Zhang and Nanyu Zhong discovered that Net-SNMP incorrectly handled
memory operations when processing certain requests. A remote attacker could
use this issue to cause Net-SNMP to crash, resulting in a denial of
service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 22.04
Ubuntu 20.04
Ubuntu 18.04

After a standard system update you need to restart snmpd to make all the
necessary changes.