Your submission was sent successfully! Close

USN-5510-1: X.Org X Server vulnerabilities

12 July 2022

Several security issues were fixed in X.Org X Server.

Releases

Packages

Details

Jan-Niklas Sohn discovered that the X.Org X Server incorrectly handled
certain inputs. An attacker could use this issue to cause the server to
crash, resulting in a denial of service, or possibly execute arbitrary
code and escalate privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 22.04
Ubuntu 21.10
Ubuntu 20.04
Ubuntu 18.04

After a standard system update you need to reboot your computer to make all
the necessary changes.

Related notices

  • USN-5510-2: xserver-xorg-legacy-hwe-16.04, xorg-server-source, xmir, xorg-server, xserver-xorg-dev-hwe-16.04, xserver-common, xnest, xserver-xorg-xmir, xserver-xephyr-hwe-16.04, xorg-server-source-hwe-16.04, xserver-xorg-core-hwe-16.04, xorg-server-hwe-16.04, xserver-xorg-legacy, xvfb, xserver-xorg-dev, xdmx, xserver-xephyr, xdmx-tools, xmir-hwe-16.04, xwayland, xserver-xorg-core, xwayland-hwe-16.04