Your submission was sent successfully! Close

USN-5309-1: virglrenderer vulnerabilities

28 February 2022

Several security issues were fixed in virglrenderer.

Releases

Packages

Details

It was discovered that virglrenderer incorrectly handled memory. An
attacker inside a guest could use this issue to cause virglrenderer to
crash, resulting in a denial of service, or possibly execute arbitrary
code. (CVE-2022-0135)

It was discovered that virglrenderer incorrectly initialized memory. An
attacker inside a guest could possibly use this issue to obtain sensitive
host information. (CVE-2022-0175)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 21.10
Ubuntu 20.04

After a standard system update you need to restart all virtual machines to
make all the necessary changes.