USN-4294-1: OpenSMTPD vulnerabilities

02 March 2020

Several security issues were fixed in opensmtpd.

Releases

Packages

  • opensmtpd - secure, reliable, lean, and easy-to configure SMTP server

Details

It was discovered that OpenSMTPD mishandled certain input. A remote,
unauthenticated attacker could use this vulnerability to execute arbitrary
shell commands as any non-root user. (CVE-2020-8794)

It was discovered that OpenSMTPD did not properly handle hardlinks under
certain conditions. An unprivileged local attacker could read the first
line of any file on the filesystem. (CVE-2020-8793)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.