USN-4093-1: Linux kernel vulnerabilities

13 August 2019

Several security issues were fixed in the Linux kernel.

Releases

Packages

Details

It was discovered that a heap buffer overflow existed in the Marvell
Wireless LAN device driver for the Linux kernel. An attacker could use this
to cause a denial of service (system crash) or possibly execute arbitrary
code. (CVE-2019-10126)

Andrei Vlad Lutas and Dan Lutas discovered that some x86 processors
incorrectly handle SWAPGS instructions during speculative execution. A
local attacker could use this to expose sensitive information (kernel
memory). (CVE-2019-1125)

It was discovered that the PowerPC dlpar implementation in the Linux kernel
did not properly check for allocation errors in some situations. A local
attacker could possibly use this to cause a denial of service (system
crash). (CVE-2019-12614)

It was discovered that a NULL pointer dereference vulnerability existed in
the Near-field communication (NFC) implementation in the Linux kernel. A
local attacker could use this to cause a denial of service (system crash).
(CVE-2019-12984)

Jann Horn discovered a use-after-free vulnerability in the Linux kernel
when accessing LDT entries in some situations. A local attacker could use
this to cause a denial of service (system crash) or possibly execute
arbitrary code. (CVE-2019-13233)

Jann Horn discovered that the ptrace implementation in the Linux kernel did
not properly record credentials in some situations. A local attacker could
use this to cause a denial of service (system crash) or possibly gain
administrative privileges. (CVE-2019-13272)

It was discovered that the Marvell Wireless LAN device driver in the Linux
kernel did not properly validate the BSS descriptor. A local attacker could
possibly use this to cause a denial of service (system crash) or possibly
execute arbitrary code. (CVE-2019-3846)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-4095-1: linux-image-4.4.0-159-generic, linux-image-powerpc-e500mc-lts-vivid, linux-image-powerpc-smp-lts-vivid, linux-image-4.4.0-159-powerpc-smp, linux-image-powerpc-smp-lts-xenial, linux-image-4.4.0-1090-aws, linux-image-powerpc-smp, linux-image-4.4.0-1122-snapdragon, linux-image-powerpc64-smp, linux-image-generic, linux-image-4.4.0-159-lowlatency, linux-image-powerpc64-smp-lts-wily, linux-image-virtual-lts-vivid, linux-image-snapdragon, linux-image-lowlatency-lts-vivid, linux-image-powerpc-smp-lts-wily, linux-kvm, linux-aws, linux-image-generic-lts-wily, linux-image-4.4.0-159-powerpc64-emb, linux-raspi2, linux-image-lowlatency-lts-wily, linux-image-generic-lpae-lts-vivid, linux-image-lowlatency-lts-utopic, linux-image-4.4.0-159-powerpc-e500mc, linux-image-4.4.0-159-powerpc64-smp, linux-image-generic-lpae, linux-image-powerpc64-emb-lts-vivid, linux-image-powerpc64-emb, linux-image-lowlatency, linux-image-virtual-lts-utopic, linux-image-powerpc-e500mc, linux-image-aws, linux-image-generic-lpae-lts-wily, linux-image-powerpc64-emb-lts-wily, linux-image-powerpc64-smp-lts-xenial, linux-image-generic-lpae-lts-xenial, linux-image-lowlatency-lts-xenial, linux-image-powerpc-smp-lts-utopic, linux-image-powerpc64-emb-lts-utopic, linux-image-powerpc64-emb-lts-xenial, linux-image-virtual-lts-xenial, linux-image-4.4.0-159-generic-lpae, linux, linux-snapdragon, linux-image-generic-lts-xenial, linux-image-powerpc-e500mc-lts-wily, linux-image-generic-lts-vivid, linux-image-virtual, linux-image-kvm, linux-image-powerpc64-smp-lts-utopic, linux-image-4.4.0-1118-raspi2, linux-image-generic-lpae-lts-utopic, linux-image-powerpc-e500mc-lts-xenial, linux-image-powerpc-e500mc-lts-utopic, linux-image-raspi2, linux-image-4.4.0-1054-kvm, linux-image-powerpc64-smp-lts-vivid, linux-image-virtual-lts-wily, linux-image-generic-lts-utopic
  • USN-4118-1: linux-image-4.15.0-1047-aws, linux-image-aws, linux-aws, linux-image-aws-hwe, linux-aws-hwe
  • USN-4096-1: linux-image-5.0.0-1012-aws, linux-image-aws, linux-image-4.15.0-1045-aws, linux-aws, linux-image-aws-hwe, linux-aws-hwe
  • USN-4095-2: linux-image-4.4.0-159-generic, linux-image-powerpc-smp-lts-xenial, linux-image-4.4.0-159-powerpc-smp, linux-image-4.4.0-1050-aws, linux-image-4.4.0-159-lowlatency, linux-aws, linux-image-4.4.0-159-powerpc64-emb, linux-image-4.4.0-159-powerpc-e500mc, linux-image-4.4.0-159-powerpc64-smp, linux-image-aws, linux-image-powerpc64-smp-lts-xenial, linux-image-lowlatency-lts-xenial, linux-image-powerpc64-emb-lts-xenial, linux-image-virtual-lts-xenial, linux-image-4.4.0-159-generic-lpae, linux-image-generic-lts-xenial, linux-image-powerpc-e500mc-lts-xenial, linux-lts-xenial, linux-image-generic-lpae-lts-xenial
  • USN-4094-1: linux-image-4.15.0-58-generic, linux-image-gke-4.15, linux-image-oem, linux-image-4.15.0-1021-oracle, linux-image-lowlatency-hwe-16.04-edge, linux-image-generic, linux-image-lowlatency-hwe-16.04, linux-image-4.15.0-1050-oem, linux-image-snapdragon, linux-kvm, linux-image-generic-lpae-hwe-16.04, linux-raspi2, linux-azure, linux-image-generic-hwe-16.04-edge, linux-image-4.15.0-1043-raspi2, linux-image-4.15.0-1060-snapdragon, linux-image-generic-lpae, linux-hwe, linux-image-generic-hwe-16.04, linux-image-gcp, linux-image-lowlatency, linux-image-4.15.0-1040-gke, linux-image-virtual-hwe-16.04-edge, linux-gcp, linux-oracle, linux-image-oracle, linux, linux-snapdragon, linux-image-4.15.0-1040-gcp, linux-image-virtual, linux-image-kvm, linux-image-4.15.0-1042-kvm, linux-oem, linux-image-4.15.0-58-generic-lpae, linux-image-raspi2, linux-image-4.15.0-58-lowlatency, linux-image-virtual-hwe-16.04, linux-image-gke, linux-image-generic-lpae-hwe-16.04-edge, linux-gke-4.15
  • USN-4117-1: linux-image-5.0.0-1014-aws, linux-image-aws, linux-aws