USN-3862-1: Irssi vulnerability

17 January 2019

Irssi could be made to crash or execute arbitrary code if it received a specially crafted input.

Releases

Packages

  • irssi - terminal based IRC client

Details

It was discovered that Irssi incorrectly handled certain inputs.
An attacker could possibly use this issue to cause a denial of service
or to execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04

After a standard system update you need to restart Irssi to make all the necessary changes.

References