CVE-2019-5882

Published: 09 January 2019

Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
irssi
Launchpad, Ubuntu, Debian
Upstream
Released (1.1.2-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.5-1ubuntu4.1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.8.19-1ubuntu1.8)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.8.15-5ubuntu3.6])
Patches:
Upstream: https://github.com/irssi/irssi//commit/8684ccb45c267fdeaaa779fce9323047aa5a9e38