Your submission was sent successfully! Close

USN-3820-2: Linux kernel (HWE) vulnerabilities

14 November 2018

Several security issues were fixed in the Linux kernel.

Releases

Packages

  • linux-azure - Linux kernel for Microsoft Azure Cloud systems
  • linux-gcp - Linux kernel for Google Cloud Platform (GCP) systems
  • linux-hwe - Linux hardware enablement (HWE) kernel

Details

USN-3820-1 fixed vulnerabilities in the Linux kernel for Ubuntu 18.04
LTS. This update provides the corresponding updates for the Linux
Hardware Enablement (HWE) kernel from Ubuntu 18.04 LTS for Ubuntu
16.04 LTS.

Felix Wilhelm discovered that the Xen netback driver in the Linux kernel
did not properly perform input validation in some situations. An attacker
could use this to cause a denial of service (system crash) or possibly
execute arbitrary code. (CVE-2018-15471)

It was discovered that the generic SCSI driver in the Linux kernel did not
properly enforce permissions on kernel memory access. A local attacker
could use this to expose sensitive information or possibly elevate
privileges. (CVE-2017-13168)

It was discovered that an integer overflow existed in the CD-ROM driver of
the Linux kernel. A local attacker could use this to expose sensitive
information (kernel memory). (CVE-2018-16658)

It was discovered that an integer overflow existed in the HID Bluetooth
implementation in the Linux kernel that could lead to a buffer overwrite.
An attacker could use this to cause a denial of service (system crash) or
possibly execute arbitrary code. (CVE-2018-9363)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-3753-2: linux-aws, linux-image-4.4.0-134-generic, linux-image-extra-4.4.0-134-generic, linux-image-4.4.0-134-powerpc64-emb, linux-image-4.4.0-134-powerpc-e500mc, linux-image-4.4.0-1028-aws, linux-lts-xenial, linux-image-4.4.0-134-lowlatency, linux-image-4.4.0-134-generic-lpae, linux-image-4.4.0-134-powerpc64-smp, linux-image-4.4.0-134-powerpc-smp
  • USN-3797-1: linux-image-4.4.0-138-powerpc-smp, linux-aws, linux-image-4.4.0-1036-kvm, linux-snapdragon, linux-raspi2, linux-image-4.4.0-1103-snapdragon, linux-image-4.4.0-138-powerpc-e500mc, linux-image-extra-4.4.0-138-generic, linux-image-4.4.0-138-powerpc64-smp, linux-image-4.4.0-1099-raspi2, linux-kvm, linux-image-4.4.0-138-powerpc64-emb, linux-image-4.4.0-138-generic, linux-image-4.4.0-1070-aws, linux-image-4.4.0-138-generic-lpae, linux-image-4.4.0-138-lowlatency, linux
  • USN-3820-1: linux-image-unsigned-4.15.0-1031-azure, linux-oem, linux-image-4.15.0-1026-kvm, linux-gcp, linux-image-4.15.0-1028-raspi2, linux-image-unsigned-4.15.0-1024-gcp, linux-image-4.15.0-39-generic, linux-aws, linux-raspi2, linux-image-4.15.0-1027-aws, linux-azure, linux-image-4.15.0-39-snapdragon, linux-image-4.15.0-39-lowlatency, linux-image-unsigned-4.15.0-39-lowlatency, linux-kvm, linux, linux-image-unsigned-4.15.0-1026-oem, linux-image-4.15.0-39-generic-lpae, linux-image-unsigned-4.15.0-39-generic
  • USN-3822-2: linux-image-3.13.0-162-generic, linux-image-generic-lpae-lts-trusty, linux-image-3.13.0-162-generic-lpae, linux-image-generic-lts-trusty, linux-lts-trusty
  • USN-3819-1: linux-image-4.18.0-11-generic, linux-image-4.18.0-11-snapdragon, linux-image-gcp, linux-image-raspi2, linux-gcp, linux-image-4.18.0-1004-kvm, linux-image-lowlatency, linux-image-kvm, linux-aws, linux-raspi2, linux-image-generic, linux-image-gke, linux-image-4.18.0-1004-aws, linux-image-4.18.0-1006-raspi2, linux-image-4.18.0-11-lowlatency, linux-image-generic-lpae, linux-image-4.18.0-11-generic-lpae, linux-kvm, linux-image-aws, linux, linux-image-snapdragon, linux-image-4.18.0-1003-gcp
  • USN-3820-3: linux-image-unsigned-4.15.0-1031-azure, linux-azure
  • USN-3822-1: linux-image-3.13.0-162-powerpc64-emb, linux-image-3.13.0-162-generic, linux-image-3.13.0-162-powerpc-e500mc, linux-image-extra-3.13.0-162-generic, linux-image-3.13.0-162-powerpc-smp, linux-image-3.13.0-162-powerpc-e500, linux-image-3.13.0-162-lowlatency, linux, linux-image-3.13.0-162-generic-lpae, linux-image-3.13.0-162-powerpc64-smp
  • USN-3753-1: linux-aws, linux-snapdragon, linux-image-4.4.0-134-generic, linux-raspi2, linux-image-extra-4.4.0-134-generic, linux-image-4.4.0-134-powerpc64-emb, linux-kvm, linux-image-4.4.0-134-powerpc-e500mc, linux-image-4.4.0-1099-snapdragon, linux-image-4.4.0-1032-kvm, linux-image-4.4.0-1066-aws, linux-image-4.4.0-134-lowlatency, linux-image-4.4.0-134-generic-lpae, linux-image-4.4.0-134-powerpc64-smp, linux, linux-image-4.4.0-134-powerpc-smp, linux-image-4.4.0-1095-raspi2
  • USN-3797-2: linux-aws, linux-image-4.4.0-138-powerpc-e500mc, linux-image-4.4.0-1032-aws, linux-image-extra-4.4.0-138-generic, linux-image-4.4.0-138-powerpc64-smp, linux-image-4.4.0-138-powerpc64-emb, linux-lts-xenial, linux-image-4.4.0-138-lowlatency, linux-image-4.4.0-138-generic, linux-image-4.4.0-138-generic-lpae, linux-image-4.4.0-138-powerpc-smp