Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

USN-3766-1: PHP vulnerabilities

18 September 2018

Several security issues were fixed in PHP.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Releases

Packages

  • php5 - HTML-embedded scripting language interpreter
  • php7.0 - HTML-embedded scripting language interpreter
  • php7.2 - HTML-embedded scripting language interpreter

Details

It was discovered that PHP incorrectly handled restarting certain child
processes when php-fpm is used. A remote attacker could possibly use this
issue to cause a denial of service. This issue was only addressed in Ubuntu
18.04 LTS. (CVE-2015-9253)

It was discovered that PHP incorrectly handled certain exif tags in JPEG
images. A remote attacker could possibly use this issue to cause PHP to
crash, resulting in a denial of service. (CVE-2018-14851, CVE-2018-14883)

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04

In Ubuntu 16.04 LTS and Ubuntu 18.04 LTS, this update uses a new upstream
release, which includes additional bug fixes.

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-4279-1: php7.2-cli, php7.0-fpm, php7.0-interbase, php5-pgsql, php7.3-json, php-pear, libphp5-embed, php7.2-xmlrpc, php7.3-common, php7.0-mbstring, php7.0-bcmath, php7.3-sybase, php7.2-readline, php7.0-readline, php7.2-imap, php7.3-ldap, php5-gmp, php7.3-curl, php7.0-xml, php7.2-zip, php7.0-recode, php7.3-pgsql, php7.3-pspell, php7.2-xml, php5-sqlite, php7.3-dba, php7.0-cli, php7.2-xsl, php7.3-cli, php7.0-intl, php7.2-gd, php7.2-odbc, php7.3-intl, libapache2-mod-php7.3, php7.2-json, php7.0-json, php7.3-xmlrpc, php5-xmlrpc, php7.0-sybase, php5, php5-ldap, php7.3-opcache, php7.2-snmp, php7.2-dba, php7.2-enchant, php7.0-imap, php7.2-common, php7.0-odbc, php7.3-bz2, libapache2-mod-php5filter, php7.0-curl, php7.3-interbase, libphp7.2-embed, php7.3-recode, php7.3-tidy, php5-cgi, php7.3-bcmath, php7.2-cgi, php5-recode, php7.2-opcache, libapache2-mod-php7.0, php7.0-soap, php5-odbc, php7.2-curl, php5-mysqlnd, php7.2, php7.3-sqlite3, php7.2-mbstring, php7.3-cgi, php7.0-mysql, php7.3-mbstring, php7.0-phpdbg, libphp7.3-embed, php5-pspell, php7.3-phpdbg, php7.0-pspell, php7.2-sybase, php7.0-opcache, php7.2-sqlite3, php5-tidy, libapache2-mod-php7.2, php7.0-dev, php7.3-odbc, php5-cli, php7.2-bz2, php7.0, php7.3-dev, php5-enchant, php7.2-gmp, php7.2-dev, php5-fpm, php5-xsl, php7.2-fpm, php7.3-fpm, php5-readline, php5-common, php7.2-bcmath, php7.3-xsl, php7.3-xml, php7.3-imap, php7.0-bz2, php7.0-ldap, libapache2-mod-php5, php7.0-sqlite3, php5-dev, php5-mysql, php5-gd, php7.3-enchant, php7.3-mysql, php7.0-xmlrpc, php5-snmp, php5-curl, php7.0-dba, php7.3-zip, php7.2-pgsql, php7.3-readline, php5-intl, php7.2-recode, php7.3-soap, php5-sybase, php7.0-gmp, php7.0-pgsql, php7.0-tidy, php7.2-soap, php7.0-cgi, php7.3-gmp, php7.2-ldap, php7.0-mcrypt, php7.2-phpdbg, php7.0-common, php7.2-intl, php7.0-xsl, php7.0-gd, php7.2-tidy, php7.3, php7.2-interbase, libphp7.0-embed, php7.2-pspell, php7.3-gd, php7.0-enchant, php7.2-mysql, php7.3-snmp, php7.0-snmp, php7.0-zip
  • USN-5300-1: php7.0-fpm, php7.0-interbase, php7.0-xmlrpc, php7.0-dba, php7.0-json, php7.0-dev, php7.0-sybase, php7.0, php7.0-mbstring, php7.0-bcmath, php7.0-imap, php7.0-odbc, php7.0-gmp, php7.0-pgsql, php7.0-curl, php7.0-readline, php7.0-tidy, php7.0-cgi, php7.0-xml, php7.0-mcrypt, php7.0-recode, php7.0-common, libapache2-mod-php7.0, php7.0-xsl, php7.0-soap, php7.0-gd, php7.0-bz2, php7.0-mysql, php7.0-ldap, php7.0-phpdbg, php7.0-sqlite3, php7.0-cli, libphp7.0-embed, php7.0-enchant, php7.0-intl, php7.0-pspell, php7.0-snmp, php7.0-zip, php7.0-opcache
  • USN-3766-2: php5-cgi, libapache2-mod-php5, php5-fpm, php5-cli, php5