Your submission was sent successfully! Close

USN-3234-2: Linux kernel (Xenial HWE) vulnerabilities

15 March 2017

Several security issues were fixed in the kernel.

Releases

Packages

Details

USN-3234-1 fixed vulnerabilities in the Linux kernel for Ubuntu 16.04
LTS. This update provides the corresponding updates for the Linux
Hardware Enablement (HWE) kernel from Ubuntu 16.04 LTS for Ubuntu
14.04 LTS.

Ralf Spenneberg discovered that the ext4 implementation in the Linux kernel
did not properly validate meta block groups. An attacker with physical
access could use this to specially craft an ext4 image that causes a denial
of service (system crash). (CVE-2016-10208)

It was discovered that the Linux kernel did not clear the setgid bit during
a setxattr call on a tmpfs filesystem. A local attacker could use this to
gain elevated group privileges. (CVE-2017-5551)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-3361-1: linux-image-4.10.0-27-lowlatency, linux-hwe, linux-image-4.10.0-27-generic, linux-image-4.10.0-27-generic-lpae, linux-image-extra-4.10.0-27-generic
  • USN-3754-1: linux-image-3.13.0-157-powerpc-e500, linux-image-3.13.0-157-powerpc-smp, linux-image-3.13.0-157-lowlatency, linux-image-3.13.0-157-powerpc-e500mc, linux-image-3.13.0-157-generic, linux, linux-image-3.13.0-157-powerpc64-emb, linux-image-extra-3.13.0-157-generic, linux-image-3.13.0-157-powerpc64-smp, linux-image-3.13.0-157-generic-lpae
  • USN-3359-1: linux-image-powerpc-e500mc, linux-image-powerpc64-emb, linux-raspi2, linux-image-4.8.0-1043-raspi2, linux-image-generic, linux-image-generic-lpae, linux, linux-image-4.8.0-59-generic, linux-image-4.8.0-59-powerpc-e500mc, linux-image-4.8.0-59-powerpc64-emb, linux-image-lowlatency, linux-image-raspi2, linux-image-powerpc-smp, linux-image-4.8.0-59-powerpc-smp, linux-image-4.8.0-59-lowlatency, linux-image-4.8.0-59-generic-lpae
  • USN-3234-1: linux-image-4.4.0-1009-aws, linux-image-4.4.0-67-generic-lpae, linux-image-4.4.0-67-powerpc64-emb, linux-image-4.4.0-67-powerpc-e500mc, linux-image-4.4.0-67-powerpc-smp, linux-image-4.4.0-1048-raspi2, linux-image-4.4.0-67-powerpc64-smp, linux-image-4.4.0-67-generic, linux-gke, linux-image-4.4.0-1006-gke, linux-image-extra-4.4.0-1006-gke, linux-raspi2, linux-snapdragon, linux-image-4.4.0-67-lowlatency, linux-aws, linux, linux-image-extra-4.4.0-67-generic, linux-image-4.4.0-1051-snapdragon