Your submission was sent successfully! Close

USN-306-1: MySQL 4.1 vulnerability

27 June 2006

MySQL 4.1 vulnerability

Releases

Details

MySQL did not correctly handle NULL as the second argument to the
str_to_date() function. An authenticated user could exploit this to
crash the server.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 5.10
  • mysql-server-4.1 - 4.1.12-1ubuntu3.6

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References